]> git.kernelconcepts.de Git - meta-kc-bsp.git/blob - recipes-bsp/application/custom-appstart_1.0.bb
start-application: silence some calls, run chromium with GPU disabled pre default
[meta-kc-bsp.git] / recipes-bsp / application / custom-appstart_1.0.bb
1 DESCRIPTION = "Application launch example"
2 SECTION = "application"
3 PRIORITY = "optional"
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7 SRC_URI = "file://StartApplication.sh \
8            file://logo.pnm \
9            "
10
11 INITSCRIPT_NAME = "StartApplication.sh"
12 INITSCRIPT_PARAMS = "defaults 80"
13
14 inherit update-rc.d
15
16 do_compile () {
17 }
18
19 do_install () {
20         install -d ${D}/etc/init.d
21         install -m755 ${WORKDIR}/StartApplication.sh ${D}/etc/init.d
22         install -d ${D}/opt/bitmaps
23         install -m644 ${WORKDIR}/logo.pnm ${D}/opt/bitmaps/
24 }
25
26 FILES_${PN} += "/etc /opt/bitmaps"