]> git.kernelconcepts.de Git - meta-kc-bsp.git/blob - recipes-bsp/dotsplash/dotsplash_git.bb
dotsplash: Update to latest git fixinf console switch and exit issue.
[meta-kc-bsp.git] / recipes-bsp / dotsplash / dotsplash_git.bb
1 SUMMARY = "./dotsplash - a tiny and customizable splash screen"
2 LICENSE = "GPLv2"
3 PV = "1.0+git${SRCPV}"
4 SRCREV = "3b6c0abd70aadc2ceb60ec523957002de9dba5bb"
5
6
7 LIC_FILES_CHKSUM = "file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
8
9 SRC_URI = "git://git@gitlab.kernelconcepts.de:2224/danb/dotsplash.git;protocol=ssh \
10           file://dotsplash-default \
11           file://dotsplash-init \
12           file://splashfuncs"
13
14 inherit pkgconfig update-rc.d meson
15
16
17 S = "${WORKDIR}/git"
18
19 FILES_${PN} += "/mnt/.psplash/"
20
21 do_install_append() {
22     install -d ${D}/mnt/.psplash/
23     install -d ${D}${sysconfdir}/init.d/
24     install -m 0755 ${WORKDIR}/dotsplash-init ${D}${sysconfdir}/init.d/dotsplash.sh
25     install -d ${D}${sysconfdir}/default/
26     install -m 0644 ${WORKDIR}/dotsplash-default ${D}${sysconfdir}/default/dotsplash
27     install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
28     cd ${D}/${bindir}
29     ln -s dotsplash-write psplash-write
30 }
31
32 INITSCRIPT_NAME = "dotsplash.sh"
33 INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
34
35 RRECOMMENDS_${PN} = "${PN}-theme-mucross"
36
37 python populate_packages_prepend () {
38     themedir = d.expand('${datadir}/dotsplash/themes')
39     do_split_packages(d, themedir, '^(.*)$',
40                      'dotsplash-theme-%s', './dotsplash theme %s',
41                       extra_depends='', allow_dirs=True, prepend=True)
42 }
43
44 PACKAGES_DYNAMIC += "^dotsplash-theme-.*"
45