]> git.kernelconcepts.de Git - meta-kc-bsp.git/blob - recipes-bsp/dotsplash/dotsplash_git.bb
dotsplash: Support writing custom parameters to config file
[meta-kc-bsp.git] / recipes-bsp / dotsplash / dotsplash_git.bb
1 SUMMARY = "./dotsplash - a tiny and customizable splash screen"
2 LICENSE = "GPLv2"
3 PV = "1.0+git${SRCPV}"
4 SRCREV = "7179a8b40c25cfd53c5eeac462086a6386d9a1af"
5
6
7 LIC_FILES_CHKSUM = "file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
8
9 SRC_URI = "git://git@gitlab.kernelconcepts.de:2224/danb/dotsplash.git;protocol=ssh \
10           file://dotsplash-default \
11           file://dotsplash-init \
12           file://splashfuncs"
13
14 inherit pkgconfig update-rc.d meson
15
16 DOTSPLASH_THEME ?= "kc-800"
17 DOTSPLASH_THEME_lamobo-r1 ?= "kc-fullhd"
18
19 DOTSPLASH_PARAMS ?= "-s 15 --theme ${DOTSPLASH_THEME}"
20
21 S = "${WORKDIR}/git"
22
23 FILES_${PN} += "/mnt/.psplash/"
24
25 do_install_append() {
26     install -d ${D}/mnt/.psplash/
27     install -d ${D}${sysconfdir}/init.d/
28     install -m 0755 ${WORKDIR}/dotsplash-init ${D}${sysconfdir}/init.d/dotsplash.sh
29     install -d ${D}${sysconfdir}/default/
30     sed -i 's/@PARAMS@/${DOTSPLASH_PARAMS}/g' ${WORKDIR}/dotsplash-default
31     install -m 0644 ${WORKDIR}/dotsplash-default ${D}${sysconfdir}/default/dotsplash
32     install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
33     cd ${D}/${bindir}
34     ln -s dotsplash-write psplash-write
35 }
36
37 INITSCRIPT_NAME = "dotsplash.sh"
38 INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
39
40 RRECOMMENDS_${PN} = "${PN}-theme-mucross"
41
42 python populate_packages_prepend () {
43     themedir = d.expand('${datadir}/dotsplash/themes')
44     do_split_packages(d, themedir, '^(.*)$',
45                      'dotsplash-theme-%s', './dotsplash theme %s',
46                       extra_depends='', allow_dirs=True, prepend=True)
47 }
48
49 PACKAGES_DYNAMIC += "^dotsplash-theme-.*"