]> git.kernelconcepts.de Git - meta-kc-bsp.git/blob - recipes-bsp/dotsplash/dotsplash_git.bb
dotsplash: pull themes package into image
[meta-kc-bsp.git] / recipes-bsp / dotsplash / dotsplash_git.bb
1 SUMMARY = "./dotsplash - a tiny and customizable splash screen"
2 LICENSE = "GPLv2"
3 PV = "1.0+git${SRCPV}"
4 SRCREV = "eac58fd508efaa3215094085daa06a58d6d7a75c"
5
6
7 LIC_FILES_CHKSUM = "file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
8
9 SRC_URI = "git://git@gitlab.kernelconcepts.de:2224/danb/mucross_psplash.git;protocol=ssh \
10           file://dotsplash-default \
11           file://dotsplash-init \
12           file://splashfuncs"
13
14 inherit pkgconfig update-rc.d meson
15
16
17 S = "${WORKDIR}/git"
18
19 FILES_${PN} += "/mnt/.dotsplash/"
20
21 PACKAGES =+ "${PN}-themes"
22 FILES_${PN}-themes += "${datadir}/dotsplash/themes/*"
23
24 do_install_append() {
25     install -d ${D}/mnt/.dotsplash/
26     install -d ${D}${sysconfdir}/init.d/
27     install -m 0755 ${WORKDIR}/dotsplash-init ${D}${sysconfdir}/init.d/dotsplash.sh
28     install -d ${D}${sysconfdir}/default/
29     install -m 0644 ${WORKDIR}/dotsplash-default ${D}${sysconfdir}/default/dotsplash
30     install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
31 }
32
33 INITSCRIPT_NAME = "dotsplash.sh"
34 INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
35
36 RRECOMMENDS_${PN} = "${PN}-themes"