]> git.kernelconcepts.de Git - meta-kc-bsp.git/blob - recipes-support/overlayfs-tools/overlayfs-tools_git.bb
xinput-calibrator: disable autostart
[meta-kc-bsp.git] / recipes-support / overlayfs-tools / overlayfs-tools_git.bb
1 SUMMARY = "Utitlites fpr working with OverlayFS"
2 HOMEPAGE = "https://github.com/kmxz/overlayfs-tools"
3 SECTION = "Applications/System"
4 LICENSE = "WTFPL"
5 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69"
6
7 DEPENDS = "attr"
8
9 SRCREV = "0d44989f1ab7f2e0f565e58f9aff7a9cffb32cd7"
10 PV = "0.1+git${SRCPV}"
11
12 S = "${WORKDIR}/git"
13 B = "${S}"
14
15 SRC_URI = "git://github.com/kmxz/overlayfs-tools \
16            file://0001-Drop-hard-coded-compiler-stuff.patch \
17            file://0002-Fix-linking.patch \
18            "
19
20 inherit base
21
22 do_configure () {
23 }
24
25 do_compile () {
26         oe_runmake overlay
27 }
28
29 do_install() {
30         install -d ${D}${bindir}
31         install -m 755 ${B}/overlay ${D}/${bindir}/overlay
32 }
33