]> git.kernelconcepts.de Git - meta-kc-bsp.git/blobdiff - recipes-bsp/dotsplash/dotsplash_git.bb
dotsplash: Update to latest git, add topasa900
[meta-kc-bsp.git] / recipes-bsp / dotsplash / dotsplash_git.bb
index faa9ea520f0d6c42f2a4d457e4e57555120efc64..870127e0b7c15a08b38aa918588ef61221ccdd6f 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "./dotsplash - a tiny and customizable splash screen"
 LICENSE = "GPLv2"
 PV = "1.0+git${SRCPV}"
-SRCREV = "c34e58b2d0be3848c041c310232db6b1e4e4132b"
+SRCREV = "ff34b85bfed5401910b2bc28a150a347f26ce97f"
 
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
@@ -13,6 +13,11 @@ SRC_URI = "git://git@gitlab.kernelconcepts.de:2224/danb/dotsplash.git;protocol=s
 
 inherit pkgconfig update-rc.d meson
 
+DOTSPLASH_THEME ?= "kc-800"
+DOTSPLASH_THEME_lamobo-r1 ?= "kc-fullhd"
+DOTSPLASH_THEME_topasa900 ?= "kc-320"
+
+DOTSPLASH_PARAMS ?= "-s 15 --theme ${DOTSPLASH_THEME}"
 
 S = "${WORKDIR}/git"
 
@@ -23,6 +28,7 @@ do_install_append() {
     install -d ${D}${sysconfdir}/init.d/
     install -m 0755 ${WORKDIR}/dotsplash-init ${D}${sysconfdir}/init.d/dotsplash.sh
     install -d ${D}${sysconfdir}/default/
+    sed -i 's/@PARAMS@/${DOTSPLASH_PARAMS}/g' ${WORKDIR}/dotsplash-default
     install -m 0644 ${WORKDIR}/dotsplash-default ${D}${sysconfdir}/default/dotsplash
     install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
     cd ${D}/${bindir}
@@ -41,5 +47,4 @@ python populate_packages_prepend () {
                       extra_depends='', allow_dirs=True, prepend=True)
 }
 
-PACKAGES_DYNAMIC += "^dotsplash-theme-.*"
-            
\ No newline at end of file
+PACKAGES_DYNAMIC += "^dotsplash-theme-.*"            
\ No newline at end of file