]> git.kernelconcepts.de Git - meta-nanopi.git/blob - recipes-tools/nanoboot/nanoboot_git.bb
ap6210-firmware-nanopi: Install firmware to proper directory
[meta-nanopi.git] / recipes-tools / nanoboot / nanoboot_git.bb
1 DESCRIPTION = "Minimalistic bootloader for NanoPi"
2 HOMEPAGE = "https://github.com/ARMWorks/NanoPi-nanoboot"
3 SECTION = "bootloaders"
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=a23a74b3f4caf9616230789d94217acb"
6
7 SRCREV = "24adb19902ad48834800eb4e6fd6b87bd2faed85"
8 PV = "v0.0+git${SRCPV}"
9
10 SRC_URI = "git://github.com/ARMWorks/NanoPi-nanoboot.git;protocol=https;branch=master;rev=24adb19902ad48834800eb4e6fd6b87bd2faed85 \
11            file://nanoboot.txt"
12
13 S = "${WORKDIR}/git"
14
15 PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17 inherit deploy
18
19
20 EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
21 FILES_${PN} = "/boot ${sysconfdir}"
22
23 do_configure () {
24 }
25
26 do_compile () {
27         oe_runmake
28 }
29
30 do_install () {
31         install -d ${D}/boot
32         install ${S}/build/nanoboot.bin ${D}/boot/
33         install ${WORKDIR}/nanoboot.txt ${D}/boot/
34 }
35
36 do_deploy () {
37         install -d ${DEPLOYDIR}
38         install ${S}/build/nanoboot.bin ${DEPLOYDIR}/
39         install ${WORKDIR}/nanoboot.txt ${DEPLOYDIR}/
40 }
41
42 addtask deploy before do_build after do_compile