]> git.kernelconcepts.de Git - meta-nanopi.git/blobdiff - recipes-graphics/images/nanopi-image-x11.bb
nanopi-image-x11: Add simple X11 image
[meta-nanopi.git] / recipes-graphics / images / nanopi-image-x11.bb
diff --git a/recipes-graphics/images/nanopi-image-x11.bb b/recipes-graphics/images/nanopi-image-x11.bb
new file mode 100644 (file)
index 0000000..5769308
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "A compact test and discovery image for low resource boards"
+LICENSE = "MIT"
+
+IMAGE_FEATURES += "splash package-management x11-base ssh-server-dropbear "
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+
+inherit core-image
+
+IMAGE_INSTALL = "\
+    packagegroup-core-boot \
+    i2c-tools \
+    lrzsz \
+    ${CORE_IMAGE_EXTRA_INSTALL} \
+    ${TOUCH} \
+"
\ No newline at end of file